summaryrefslogtreecommitdiff
path: root/package/ftop
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-06-29 12:39:06 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-06-30 13:48:54 +0200
commit82c9989691287668d30d3fd37281af7ed106b69f (patch)
tree7c8c7bf44d53a0834cdbd0df11b3e0c62c26750b /package/ftop
parent8c1ff84efc5d3903500c32713a23dceee00b6cc7 (diff)
ftop: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ftop')
-rw-r--r--package/ftop/Config.in12
-rw-r--r--package/ftop/ftop-0001-overflow.patch17
-rw-r--r--package/ftop/ftop.mk13
3 files changed, 42 insertions, 0 deletions
diff --git a/package/ftop/Config.in b/package/ftop/Config.in
new file mode 100644
index 000000000..878574fbe
--- /dev/null
+++ b/package/ftop/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_FTOP
+ bool "ftop"
+ depends on BR2_LARGEFILE
+ select BR2_PACKAGE_NCURSES
+ help
+ Ftop is to files what top is to processes.
+ The progress of all open files and file systems can be monitored.
+
+ https://code.google.com/p/ftop/
+
+comment "ftop needs a toolchain w/ largefile"
+ depends on !BR2_LARGEFILE
diff --git a/package/ftop/ftop-0001-overflow.patch b/package/ftop/ftop-0001-overflow.patch
new file mode 100644
index 000000000..a3a27c377
--- /dev/null
+++ b/package/ftop/ftop-0001-overflow.patch
@@ -0,0 +1,17 @@
+Set tmp_buf and rate_buf to something ridiculously high to fix a buffer
+overflow when COLUMNS is large. - JeR
+
+(Taken from gentoo portage)
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+--- a/src/ftop.c 2009-02-16 07:00:00.000000000 +0100
++++ b/src/ftop.c 2013-09-06 14:42:41.788852952 +0200
+@@ -736,7 +736,7 @@
+ {
+ size_t i, j, bytes, bar_total;
+ char more_procs_ch, more_files_ch, expanded_ch;
+- char tmp_buf[80], rate_buf[80];
++ char tmp_buf[2048], rate_buf[2048];
+ char *tmp_str;
+ snapshot *s, *s_prev;
+ file_info *tmp_file;
diff --git a/package/ftop/ftop.mk b/package/ftop/ftop.mk
new file mode 100644
index 000000000..2220317d0
--- /dev/null
+++ b/package/ftop/ftop.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# ftop
+#
+################################################################################
+
+FTOP_VERSION = 1.0
+FTOP_SITE = http://ftop.googlecode.com/files/
+FTOP_DEPENDENCIES = ncurses
+FTOP_LICENSE = GPLv3+
+FTOP_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))