summaryrefslogtreecommitdiff
path: root/package/gdb/gdb.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-12-01 09:38:10 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-01 09:38:10 +0100
commitd3fa9141827999d1482dab2323507d2d0d2729c8 (patch)
treef938bb017d6c9a04e445615016b6cb2cdda8719b /package/gdb/gdb.mk
parent6ed317672c2f335985f3cd07c042842795406e09 (diff)
gdb: unbreak host-gdb with python support if python3 is enabled
Fixes http://autobuild.buildroot.net/results/ef4/ef487b495e57f098af0fe9508d430b56b0750339/ Explicitly pass the path to host-python to ensure it gets used. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gdb/gdb.mk')
-rw-r--r--package/gdb/gdb.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 8d0f76dcc..dbec760f1 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -146,7 +146,7 @@ else
endif
ifeq ($(BR2_PACKAGE_HOST_GDB_PYTHON),y)
- HOST_GDB_CONF_OPTS += --with-python
+ HOST_GDB_CONF_OPTS += --with-python=$(HOST_DIR)/usr/bin/python2
HOST_GDB_DEPENDENCIES += host-python
else
HOST_GDB_CONF_OPTS += --without-python