summaryrefslogtreecommitdiff
path: root/package/gdb
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-03-11 10:16:33 +0000
committerPeter Korsgaard <peter@korsgaard.com>2016-03-13 23:17:08 +0100
commite6a29a4f3c48b13fde2214365067e34fbb92cfd6 (patch)
treedaae34c0f1d339bdedcdc53616ca9a14e881ba4b /package/gdb
parent29ac732a9425d7137b051ebf2fd66ca24646cf90 (diff)
gdb: specify where to find lzma libraries
As reported in... https://bugs.busybox.net/show_bug.cgi?id=8786 ..., gdb fails to build with xz and expat support at the same time when using an external toolchain. This is how the problem is shown: checking for liblzma... no configure: error: missing liblzma for --with-lzma And having a deeper look in gdb/config.log we can se a message like this one: /lib64/liblzma.so.5: undefined reference to `clock_gettime@GLIBC_2.17' As Thomas said in the bug report quoted above, that error is related to the fact that it find the host's lzma. Adding --with-lzma-prefix=$(STAGING_DIR)/usr to GDB_CONF_OPTS fixes the problem. Credit-to: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gdb')
-rw-r--r--package/gdb/gdb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 32d52eb3a..f7d6339b7 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -120,6 +120,7 @@ endif
ifeq ($(BR2_PACKAGE_XZ),y)
GDB_CONF_OPTS += --with-lzma
+GDB_CONF_OPTS += --with-liblzma-prefix=$(STAGING_DIR)/usr
GDB_DEPENDENCIES += xz
else
GDB_CONF_OPTS += --without-lzma