summaryrefslogtreecommitdiff
path: root/package/git
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-04 14:44:43 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-04 14:44:43 +0100
commit986bbee1ff9d5c95c68caa19a0f7459391f81fbd (patch)
treeb941967f3d4b1e8e6a4211ba5b5e6ff54ca6c269 /package/git
parente76467031e226aa348570c00c7e4a5ad60ae6c75 (diff)
git: fix config option used to detect libcurl availability
BR2_PACKAGE_CURL is currently used by the git package to find out if libcurl is available. While indeed BR2_PACKAGE_CURL indicates that libcurl is available, it is not the most appropriate option for this: BR2_PACKAGE_LIBCURL is better. BR2_PACKAGE_LIBCURL indicates that libcurl is available, while BR2_PACKAGE_CURL indicates that both libcurl and the curl program are available. Only the former is needed by Git. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/git')
-rw-r--r--package/git/git.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/git/git.mk b/package/git/git.mk
index 2bd6a0158..54f7fbf30 100644
--- a/package/git/git.mk
+++ b/package/git/git.mk
@@ -26,7 +26,7 @@ else
GIT_CONF_OPTS += --without-libpcre
endif
-ifeq ($(BR2_PACKAGE_CURL),y)
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
GIT_DEPENDENCIES += libcurl
GIT_CONF_OPTS += --with-curl
else