summaryrefslogtreecommitdiff
path: root/package/gpm
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2015-02-27 14:20:00 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-02-27 14:47:53 +0100
commitc6c8fbcdf4f89100238d89d393689df1c72f1647 (patch)
tree34df7dec9c9a9693f151b0740eaa46069992109e /package/gpm
parentb17e5352cad1214f10ebed5ad68a9bfbcc280690 (diff)
gpm: avoid use of host emacs
configure looks for emacs installation to byte compile .el files. This may break the build if the host installed emacs is missing needed dependencies. Since we don't (yet?) package emacs for target, just disable detection of emacs. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gpm')
-rw-r--r--package/gpm/gpm.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/gpm/gpm.mk b/package/gpm/gpm.mk
index dcf075a9c..dee620811 100644
--- a/package/gpm/gpm.mk
+++ b/package/gpm/gpm.mk
@@ -15,7 +15,8 @@ GPM_DEPENDENCIES = host-bison
# if not already installed in staging dir, gpm Makefile may fail to find some
# of the headers needed to generate build dependencies, the first time it is
# built. CPPFLAGS is used to pass the right include path to dependency rules.
-GPM_CONF_ENV = CPPFLAGS="$(TARGET_CPPFLAGS) -I$(@D)/src/headers/"
+GPM_CONF_ENV = CPPFLAGS="$(TARGET_CPPFLAGS) -I$(@D)/src/headers/" \
+ ac_cv_path_emacs=no
# For some reason, Microblaze gcc does not define __ELF__, which gpm
# configure script uses to determine whether the architecture uses ELF