summaryrefslogtreecommitdiff
path: root/package/hostapd
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-03 22:41:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-11 22:48:13 +0100
commit665e13c85e1fd216499cdd335a88a4d1c20f175f (patch)
tree5ecc87c54905105b96cbe9891028ef8eb3d713b1 /package/hostapd
parent2d23d40279be39f70553974de11a5fc088622911 (diff)
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Config.in4
-rw-r--r--package/hostapd/hostapd.mk4
2 files changed, 4 insertions, 4 deletions
diff --git a/package/hostapd/Config.in b/package/hostapd/Config.in
index 6ca396ee3..656645bff 100644
--- a/package/hostapd/Config.in
+++ b/package/hostapd/Config.in
@@ -16,12 +16,12 @@ if BR2_PACKAGE_HOSTAPD
config BR2_PACKAGE_HOSTAPD_EAP
bool "Enable EAP"
- depends on !BR2_PREFER_STATIC_LIB
+ depends on !BR2_STATIC_LIBS
help
Enable support for EAP and RADIUS.
comment "hostapd EAP needs a toolchain w/ dynamic library"
- depends on BR2_PREFER_STATIC_LIB
+ depends on BR2_STATIC_LIBS
config BR2_PACKAGE_HOSTAPD_WPS
bool "Enable WPS"
diff --git a/package/hostapd/hostapd.mk b/package/hostapd/hostapd.mk
index dec9ef852..d4a530414 100644
--- a/package/hostapd/hostapd.mk
+++ b/package/hostapd/hostapd.mk
@@ -31,7 +31,7 @@ HOSTAPD_CONFIG_DISABLE =
# libnl-3 needs -lm (for rint) and -lpthread if linking statically
# And library order matters hence stick -lnl-3 first since it's appended
# in the hostapd Makefiles as in LIBS+=-lnl-3 ... thus failing
-ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ifeq ($(BR2_STATIC_LIBS),y)
HOSTAPD_LIBS += -lnl-3 -lm -lpthread
endif
@@ -42,7 +42,7 @@ endif
# Try to use openssl if it's already available
ifeq ($(BR2_PACKAGE_OPENSSL),y)
HOSTAPD_DEPENDENCIES += openssl
- HOSTAPD_LIBS += $(if $(BR2_PREFER_STATIC_LIB),-lcrypto -lz)
+ HOSTAPD_LIBS += $(if $(BR2_STATIC_LIBS),-lcrypto -lz)
HOSTAPD_CONFIG_EDITS += 's/\#\(CONFIG_TLS=openssl\)/\1/'
else
HOSTAPD_CONFIG_DISABLE += CONFIG_EAP_PWD