summaryrefslogtreecommitdiff
path: root/package/icu
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-29 13:23:34 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-29 13:23:34 +0200
commitc4019fcaa940b9687bd337e8546b4c009428595e (patch)
treefdb737e67ba4ac29026cc398cec39645aacb3491 /package/icu
parent1d001e322460fa47786f5790fd15ab367d47ab0e (diff)
icu: fix build after custom data library patch
Commit abded6bfead49d61c24a45d811a83ca082adf677 ("icu: add an option to add a custom data library file") broke the build because of an improper test on a non-qstripped variable. This commit fixes that. Fixes: http://autobuild.buildroot.org/results/02a/02a0800b01a4bf8734d601f79dc12663fe8f7542/ and many other similar occurences of the same issue. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/icu')
-rw-r--r--package/icu/icu.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/icu/icu.mk b/package/icu/icu.mk
index 208229d71..0312fac0a 100644
--- a/package/icu/icu.mk
+++ b/package/icu/icu.mk
@@ -26,9 +26,11 @@ ICU_MAKE = $(MAKE1)
ICU_SUBDIR = source
HOST_ICU_SUBDIR = source
-ifneq ($(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH),)
+ICU_CUSTOM_DATA_PATH = $(call qstrip,$(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH))
+
+ifneq ($(ICU_CUSTOM_DATA_PATH),)
define ICU_COPY_CUSTOM_DATA
- cp $(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
+ cp $(ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
endef
ICU_POST_PATCH_HOOKS += ICU_COPY_CUSTOM_DATA
endif