summaryrefslogtreecommitdiff
path: root/package/imagemagick/imagemagick.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-06-15 09:34:21 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-15 23:11:44 +0200
commitde81d2e541b9853fefe3924c7329a9949252aa0a (patch)
tree3ce4bde6eef506520730b816b244dac8b9abf744 /package/imagemagick/imagemagick.mk
parent1e03b0e1e6f7577c4c7a2310f0034eed9c5203ec (diff)
imagemagick: bump to version 7.0.2-0
Add new disables for libraries that aren't supported in buildroot and sort them for ease of maintenance. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/imagemagick/imagemagick.mk')
-rw-r--r--package/imagemagick/imagemagick.mk21
1 files changed, 12 insertions, 9 deletions
diff --git a/package/imagemagick/imagemagick.mk b/package/imagemagick/imagemagick.mk
index 74ac5a464..065f33dba 100644
--- a/package/imagemagick/imagemagick.mk
+++ b/package/imagemagick/imagemagick.mk
@@ -4,7 +4,7 @@
#
################################################################################
-IMAGEMAGICK_VERSION = 6.9.4-6
+IMAGEMAGICK_VERSION = 7.0.2-0
IMAGEMAGICK_SOURCE = ImageMagick-$(IMAGEMAGICK_VERSION).tar.xz
IMAGEMAGICK_SITE = http://www.imagemagick.org/download/releases
IMAGEMAGICK_LICENSE = Apache-2.0
@@ -12,7 +12,7 @@ IMAGEMAGICK_LICENSE_FILES = LICENSE
IMAGEMAGICK_INSTALL_STAGING = YES
IMAGEMAGICK_CONFIG_SCRIPTS = \
- $(addsuffix -config,Magick MagickCore MagickWand Wand)
+ $(addsuffix -config,MagickCore MagickWand)
ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR),yy)
IMAGEMAGICK_CONFIG_SCRIPTS += Magick++-config
@@ -23,16 +23,19 @@ IMAGEMAGICK_CONF_ENV = ac_cv_sys_file_offset_bits=64
IMAGEMAGICK_CONF_OPTS = \
--program-transform-name='s,,,' \
--disable-openmp \
- --without-perl \
- --without-wmf \
- --without-openexr \
- --without-jp2 \
- --without-jbig \
- --without-gvc \
--without-djvu \
--without-dps \
- --without-gslib \
+ --without-flif \
--without-fpx \
+ --without-gslib \
+ --without-gvc \
+ --without-jbig \
+ --without-jp2 \
+ --without-lqr \
+ --without-openexr \
+ --without-perl \
+ --without-raqm \
+ --without-wmf \
--without-x
IMAGEMAGICK_DEPENDENCIES = host-pkgconf