summaryrefslogtreecommitdiff
path: root/package/iqvlinux/iqvlinux.mk
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-10-09 15:26:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-12 23:15:13 +0200
commit330f961ad3404708ed9a35b9b1fdc429ad65ccfe (patch)
tree91479ce976a6a65d25366c468cecb893321f6955 /package/iqvlinux/iqvlinux.mk
parent29d8481bd66a2e9a121c85212e31336c2907d873 (diff)
package/iqvlinux: new package
The PCI support needs to be checked since this driver is based on it. Otherwise the build fail with: #error "This driver requires PCI support to be available" But this message is concealed by several occurrence of this one: error: implicit declaration of function 'pci_find_bus' [-Werror=implicit-function-declaration] [Thomas: - fix minor typo in Config.in: s/Enthernet/Ethernet/ - license is "GPLv2, BSD-3c", not "GPLv2 or BSD-3c" - remove IQVLINUX_PCI_CHECK, until a proper generic solution is implemented.] Signed-off-by: Romain Naour <romain.naour@openwide.fr> Cc: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/iqvlinux/iqvlinux.mk')
-rw-r--r--package/iqvlinux/iqvlinux.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/iqvlinux/iqvlinux.mk b/package/iqvlinux/iqvlinux.mk
new file mode 100644
index 000000000..b3981fa77
--- /dev/null
+++ b/package/iqvlinux/iqvlinux.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# iqvlinux
+#
+################################################################################
+
+IQVLINUX_VERSION = 1.1.5.3
+IQVLINUX_SITE = http://sourceforge.net/projects/e1000/files/iqvlinux/$(IQVLINUX_VERSION)
+IQVLINUX_SOURCE = iqvlinux.tar.gz
+
+IQVLINUX_LICENSE = GPLv2, BSD-3c
+IQVLINUX_LICENSE_FILES = \
+ COPYING src/linux/driver/files.txt \
+ inc/linux/files.txt inc/files.txt
+
+IQVLINUX_MODULE_MAKE_OPTS = NALDIR=$(@D) KSRC=$(LINUX_DIR) CC=$(TARGET_CC)
+
+IQVLINUX_MODULE_SUBDIRS = src/linux/driver
+
+$(eval $(kernel-module))
+$(eval $(generic-package))