summaryrefslogtreecommitdiff
path: root/package/libftdi/libftdi.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-25 00:07:47 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-26 21:25:22 +0100
commitf1550e3eb082862259bc76d0312c556407a24046 (patch)
tree81551f29b3f2e853f453eeb6562ba9f12435e9c3 /package/libftdi/libftdi.mk
parentf88a49064df9993efe2ecbc2d89e3e1301b983b7 (diff)
libftdi: C++ bindings need boost
According to libftdi configure.in: """ dnl libftdi C++ wrapper. Needs boost. [...] if test "x$HAVE_BOOST" != "xyes"; then AC_MSG_ERROR(Sorry, we need the boost library for the C++ wrapper) fi """ And indeed, if you enable BR2_PACKAGE_LIBTFDI_CPP but don't have Boost enabled, the libfdipp library is not built. To fix this, this commit changes BR2_PACKAGE_LIBTFDI_CPP to select Boost. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libftdi/libftdi.mk')
-rw-r--r--package/libftdi/libftdi.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/libftdi/libftdi.mk b/package/libftdi/libftdi.mk
index 8370b0a16..28f20e354 100644
--- a/package/libftdi/libftdi.mk
+++ b/package/libftdi/libftdi.mk
@@ -15,6 +15,7 @@ LIBFDTI_CONF_OPTS = --without-examples
# configure detect it automaticaly so we need to force it
ifeq ($(BR2_PACKAGE_LIBTFDI_CPP),y)
+LIBFTDI_DEPENDENCIES += boost
LIBFDTI_CONF_OPTS += --enable-libftdipp
else
LIBFDTI_CONF_OPTS += --disable-libftdipp