summaryrefslogtreecommitdiff
path: root/package/libpfm4
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-07 11:40:35 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-07 11:40:35 +0200
commit305beebb74c75744fccb25963f9e35511b7804a2 (patch)
tree29635de762073f6c0ee998c846e00cc14624f221 /package/libpfm4
parent38454e10589993e5c7877f2fd904ba07f5865357 (diff)
libpfm4: fix static-only build
By default, libpfm4 tries to build a shared library. However, by passing CONFIG_PFMLIB_SHARED=n, we can convince it to build only a static library. Therefore, this commit uses that to fix the static-only build, therefore fixing: http://autobuild.buildroot.net/results/efa/efae782912face7c36417dfb1023228d6b137654/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libpfm4')
-rw-r--r--package/libpfm4/libpfm4.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libpfm4/libpfm4.mk b/package/libpfm4/libpfm4.mk
index 11106720a..e2fff8088 100644
--- a/package/libpfm4/libpfm4.mk
+++ b/package/libpfm4/libpfm4.mk
@@ -11,7 +11,9 @@ LIBPFM4_LICENSE = libpfm4 license
LIBPFM4_LICENSE_FILES = COPYING
LIBPFM4_INSTALL_STAGING = YES
-LIBPFM4_FLAGS = SYS=Linux ARCH=$(BR2_ARCH) CC="$(TARGET_CC)" LDCONFIG=true
+LIBPFM4_FLAGS = SYS=Linux ARCH=$(BR2_ARCH) \
+ CC="$(TARGET_CC)" LDCONFIG=true \
+ CONFIG_PFMLIB_SHARED=$(if $(BR2_STATIC_LIBS),n,y)
define LIBPFM4_BUILD_CMDS
$(MAKE) -C $(@D) $(LIBPFM4_FLAGS)