summaryrefslogtreecommitdiff
path: root/package/libsigrokdecode
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2015-01-29 12:35:40 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-02-01 23:47:35 +0100
commit9404f1a0a758d1443962ee9ac4c960f0fe23bab4 (patch)
tree5132c529fcf2334236e3f1704994ee668b085b51 /package/libsigrokdecode
parent793486e687c5c56b0dfda99ad6ecd603058dba38 (diff)
libsigrokdecode: new package
[Peter: needs libglib2+host-pkgconf, simplify pre-configure, propagate !python dependency] Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libsigrokdecode')
-rw-r--r--package/libsigrokdecode/Config.in26
-rw-r--r--package/libsigrokdecode/libsigrokdecode.mk23
2 files changed, 49 insertions, 0 deletions
diff --git a/package/libsigrokdecode/Config.in b/package/libsigrokdecode/Config.in
new file mode 100644
index 000000000..252992359
--- /dev/null
+++ b/package/libsigrokdecode/Config.in
@@ -0,0 +1,26 @@
+config BR2_PACKAGE_LIBSIGROKDECODE
+ bool "libsigrokdecode"
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_PYTHON3
+ depends on !BR2_PACKAGE_PYTHON # python3
+ depends on BR2_USE_WCHAR # libglib2/python3
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2/python3
+ depends on BR2_USE_MMU # libglib2/python3
+ help
+ Libsigrokdecode is a shared library written in C, which
+ provides (streaming) protocol decoding functionality. Say
+ yes here if you want to add this functionality to your
+ buildroot-generated sigrok suite.
+
+ This library is a part of the sigrok software suite.
+
+ http://sigrok.org/wiki/Libsigrokdecode
+
+comment "libsigrokecode needs a toolchain w/ wchar, threads"
+ depends on BR2_USE_MMU
+ depends on !BR2_PACKAGE_PYTHON
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
+comment "libsigrokdecode is not compatible with python"
+ depends on BR2_USE_MMU
+ depends on BR2_PACKAGE_PYTHON
diff --git a/package/libsigrokdecode/libsigrokdecode.mk b/package/libsigrokdecode/libsigrokdecode.mk
new file mode 100644
index 000000000..c0a4017c1
--- /dev/null
+++ b/package/libsigrokdecode/libsigrokdecode.mk
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libsigrokdecode
+#
+################################################################################
+
+LIBSIGROKDECODE_VERSION = 9177963de41c2d003d417049470eea3c98eeb2ef
+# No https access on upstream git
+LIBSIGROKDECODE_SITE = git://sigrok.org/libsigrokdecode
+LIBSIGROKDECODE_LICENSE = GPLv3+
+LIBSIGROKDECODE_LICENSE_FILES = COPYING
+# Git checkout has no configure script
+LIBSIGROKDECODE_AUTORECONF = YES
+LIBSIGROKDECODE_INSTALL_STAGING = YES
+LIBSIGROKDECODE_DEPENDENCIES = host-pkgconf libglib2 python3
+
+define LIBSIGROKDECODE_ADD_MISSING
+ mkdir -p $(@D)/autostuff
+endef
+
+LIBSIGROKDECODE_PRE_CONFIGURE_HOOKS += LIBSIGROKDECODE_ADD_MISSING
+
+$(eval $(autotools-package))