summaryrefslogtreecommitdiff
path: root/package/libstrophe
diff options
context:
space:
mode:
authorDenis Bodor <lefinnois@lefinnois.net>2014-03-12 11:04:17 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-29 13:13:08 +0100
commit1acff22d5e34a91ed6e2f87312962160612fbd3d (patch)
treec3e15021dc04c8638c6098e2d252369219531634 /package/libstrophe
parentb1069239cf2098fbdce7046627e1dc53a07acbc3 (diff)
libstrophe: new package
[Thomas: allow compilation with either expat or libxml2, reword the license description to indicate that it's MIT *or* GPLv3. ] Signed-off-by: Denis Bodor <lefinnois@lefinnois.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libstrophe')
-rw-r--r--package/libstrophe/Config.in11
-rw-r--r--package/libstrophe/libstrophe-01-make-autoreconfable.patch13
-rw-r--r--package/libstrophe/libstrophe.mk29
3 files changed, 53 insertions, 0 deletions
diff --git a/package/libstrophe/Config.in b/package/libstrophe/Config.in
new file mode 100644
index 000000000..d4e6a7d2e
--- /dev/null
+++ b/package/libstrophe/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBSTROPHE
+ bool "libstrophe"
+ select BR2_PACKAGE_OPENSSL
+ select BR2_PACKAGE_LIBXML2 if !BR2_PACKAGE_EXPAT
+ help
+ libstrophe is a lightweight XMPP client library written in C.
+ It has minimal dependencies and is configurable for various
+ environments. It runs well on both Linux, Unix, and Windows
+ based platforms.
+
+ https://github.com/strophe/libstrophe
diff --git a/package/libstrophe/libstrophe-01-make-autoreconfable.patch b/package/libstrophe/libstrophe-01-make-autoreconfable.patch
new file mode 100644
index 000000000..98da3f47c
--- /dev/null
+++ b/package/libstrophe/libstrophe-01-make-autoreconfable.patch
@@ -0,0 +1,13 @@
+Make the package autoreconfigurable
+
+Signed-off-by: Denis Bodor <lefinnois@lefinnois.net>
+
+diff -ur libstrophe.orig/Makefile.am libstrophe/Makefile.am
+--- libstrophe.orig/Makefile.am 2014-03-02 18:58:36.219753865 +0100
++++ libstrophe/Makefile.am 2014-03-02 18:58:02.739752477 +0100
+@@ -1,4 +1,4 @@
+-AUTOMAKE_OPTIONS = subdir-objects
++AUTOMAKE_OPTIONS = subdir-objects foreign
+
+ CFLAGS = -g -Wall
+
diff --git a/package/libstrophe/libstrophe.mk b/package/libstrophe/libstrophe.mk
new file mode 100644
index 000000000..1bd55c7cc
--- /dev/null
+++ b/package/libstrophe/libstrophe.mk
@@ -0,0 +1,29 @@
+################################################################################
+#
+# libstrophe
+#
+################################################################################
+
+LIBSTROPHE_VERSION = d408eaf2bbfe5ff5c56eab01463c278f9891c08e
+LIBSTROPHE_SITE = $(call github,strophe,libstrophe,$(LIBSTROPHE_VERSION))
+LIBSTROPHE_DEPENDENCIES = openssl host-pkgconf
+LIBSTROPHE_AUTORECONF = YES
+LIBSTROPHE_LICENSE = MIT or GPLv3
+LIBSTROPHE_LICENSE_FILES = MIT-LICENSE.txt GPL-LICENSE.txt
+
+# This package does not build a dynamic library, so there is nothing
+# to be installed to the target.
+LIBSTROPHE_INSTALL_STAGING = YES
+LIBSTROPHE_INSTALL_TARGET = NO
+
+ifeq ($(BR2_PACKAGE_EXPAT),y)
+# Passing --without-libxml2 doesn't work, due to how AC_ARG_WITH is
+# used in configure.ac. As long as --with-libxml2 is *not* passed, the
+# configure script assumes expat should be used.
+LIBSTROPHE_DEPENDENCIES += expat
+else
+LIBSTROPHE_CONF_OPT += --with-libxml2
+LIBSTROPHE_DEPENDENCIES += libxml2
+endif
+
+$(eval $(autotools-package))