summaryrefslogtreecommitdiff
path: root/package/luarocks
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-03-01 23:30:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-01 23:47:40 +0100
commit7669aab6b4c9a479e561d5faa9b72cce1720ccb7 (patch)
treefe5cad8b02ce604e8ad718cd20d2eca0f04b20be /package/luarocks
parent3d93589c8f318654b3cf572930541085f68adbf0 (diff)
luarocks: remove luainterpreter dependency
All packages using the luarocks infrastructure need a dependency on luainterpreter, because having the Lua interpreter for the target is needed to built native Lua modules. This dependency is already taken care of in pkg-luarocks.mk. However, host-luarocks, which is built as a dependency of the extract step of any luarocks package, also had a dependency on luainterpreter. Not only this was not necessary, but it was causing problems with 'make legal-info'. Since 'make legal-info' triggers the extraction of all packages, as soon as a luarocks package was enabled, it would trigger the build of host-luarocks, itself triggering the build of luainterpreter and therefore its dependencies, amongst which the entire cross-compilation toolchain. [Thomas: reword commit log to include more detailed explanations.] Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/luarocks')
-rw-r--r--package/luarocks/luarocks.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/luarocks/luarocks.mk b/package/luarocks/luarocks.mk
index 86e57d26b..926fd042f 100644
--- a/package/luarocks/luarocks.mk
+++ b/package/luarocks/luarocks.mk
@@ -9,7 +9,7 @@ LUAROCKS_SITE = http://luarocks.org/releases/
LUAROCKS_LICENSE = MIT
LUAROCKS_LICENSE_FILES = COPYING
-HOST_LUAROCKS_DEPENDENCIES = host-lua luainterpreter
+HOST_LUAROCKS_DEPENDENCIES = host-lua
LUAROCKS_CONFIG_DIR = $(HOST_DIR)/usr/etc/luarocks
LUAROCKS_CONFIG_FILE = $(LUAROCKS_CONFIG_DIR)/config-$(LUAINTERPRETER_ABIVER).lua