summaryrefslogtreecommitdiff
path: root/package/luarocks
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-07-29 20:18:15 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-29 20:22:58 +0200
commitb8d5182b93289e42a5e86180f1c2f60da603b8a1 (patch)
treede0c2dd3da6d8aa62ca07de5290682a7a206f497 /package/luarocks
parent4387568bbfa1c3f533c72993cbaba1f7f4e6e015 (diff)
luarocks: refactor with TARGET_FINALIZE_HOOKS
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/luarocks')
-rw-r--r--package/luarocks/luarocks.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/luarocks/luarocks.mk b/package/luarocks/luarocks.mk
index 80b9e9fb6..f4c06d6de 100644
--- a/package/luarocks/luarocks.mk
+++ b/package/luarocks/luarocks.mk
@@ -51,3 +51,10 @@ $(eval $(host-generic-package))
LUAROCKS_RUN = LUA_PATH="$(HOST_DIR)/usr/share/lua/$(LUAINTERPRETER_ABIVER)/?.lua" \
$(LUA_RUN) $(HOST_DIR)/usr/bin/luarocks
+
+define LUAROCKS_FINALIZE_TARGET
+ rm -rf $(TARGET_DIR)/usr/lib/luarocks
+endef
+
+TARGET_FINALIZE_HOOKS += LUAROCKS_FINALIZE_TARGET
+