summaryrefslogtreecommitdiff
path: root/package/mysql/mysql.mk
diff options
context:
space:
mode:
authorMarcelo Gutierrez <kuyurix@gmail.com>2014-02-12 22:39:34 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-03 23:32:16 +0100
commitce3044ec1b68a65e41b030e120ae0213dc24cda8 (patch)
tree8c7f74835773d6aafe06908778a1ddccd02c199d /package/mysql/mysql.mk
parentf7aa61c6f93981c94bafc4cc98bf7788c5c08a68 (diff)
mysql: fix debugging options
The usual --{en,dis}able-debug passed by the infrastructure are not recognised by mysql's ./configure, as it uses unusual options. Also, debugging is only meaningful to the server, not the client. Signed-off-by: Marcelo Gutierrez (UTN/FRH) <kuyurix@gmail.com> [yann.morin.1998@free.fr: actually add the options, move in server if-block] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mysql/mysql.mk')
-rw-r--r--package/mysql/mysql.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/package/mysql/mysql.mk b/package/mysql/mysql.mk
index 27afc9f86..95b30b701 100644
--- a/package/mysql/mysql.mk
+++ b/package/mysql/mysql.mk
@@ -30,8 +30,7 @@ MYSQL_CONF_OPT = \
--without-libedit \
--without-readline \
--with-low-memory \
- --enable-thread-safe-client \
- $(ENABLE_DEBUG)
+ --enable-thread-safe-client
ifeq ($(BR2_PACKAGE_MYSQL_SERVER),y)
MYSQL_DEPENDENCIES += host-mysql host-bison
@@ -57,6 +56,14 @@ MYSQL_CONF_OPT += \
--without-plugin-innodb_plugin \
--without-plugin-ndbcluster
+# Debugging is only available for the server, so no need for
+# this if-block outside of the server if-block
+ifeq ($(BR2_ENABLE_DEBUG),y)
+MYSQL_CONF_OPT += --with-debug=full
+else
+MYSQL_CONF_OPT += --without-debug
+endif
+
define HOST_MYSQL_BUILD_CMDS
$(MAKE) -C $(@D)/include my_config.h
$(MAKE) -C $(@D)/mysys libmysys.a