summaryrefslogtreecommitdiff
path: root/package/nodejs
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2017-01-22 22:05:51 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-23 19:07:04 +1100
commit5b1fc3451cab9952f5a64591b512e3c21d088961 (patch)
tree4624babbf52f1c0e763f6d13189325cc863361ec /package/nodejs
parent5fa89d2ca82bd6228b3983951648772203028504 (diff)
nodejs: unbreak 0.10.x host build
Fixes: http://autobuild.buildroot.net/results/833/8334631b54fdfd43d38ca00f42e4d5a98e3a70c4/ http://autobuild.buildroot.net/results/9c0/9c08e0b745fab671123facb4a46f60eec5afd718/ Commit 24d90db52a74 (package/nodejs: disable icu support for host build) added --with-intl=none to host configure flags to fix an issue related to icu. The 0.10.x version unfortunately doesn't understand this configure flag and errors out when provided, breaking the build: configure: error: no such option: --with-intl The 0.10.x version doesn't seem to have this icu issue (E.G. no autobuilder issues before this commit and unable to reproduce locally), so fix it by only passing --with-intl=none for the 6.9.x version. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/nodejs')
-rw-r--r--package/nodejs/nodejs.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
index 82a012ad7..042cc3fb0 100644
--- a/package/nodejs/nodejs.mk
+++ b/package/nodejs/nodejs.mk
@@ -63,7 +63,7 @@ define HOST_NODEJS_CONFIGURE_CMDS
--without-dtrace \
--without-etw \
--shared-zlib \
- --with-intl=none \
+ $(if $(BR2_PACKAGE_NODEJS_V8_ARCH_SUPPORTS),--with-intl=none) \
)
endef