summaryrefslogtreecommitdiff
path: root/package/oprofile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-22 21:29:47 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-22 21:29:47 +0100
commit953b84a930fe6872ec349fb977fc9475da501931 (patch)
tree9caa06e2c735ed19a292b1b7b83bc778647fec51 /package/oprofile
parent4bb1d97b1151ff7c3a8d89e98adf4b1ae3c72741 (diff)
oprofile: don't install shared library in BR2_STATIC_LIBS=y configs
When building with BR2_STATIC_LIBS=y, no shared library gets built, so the installation of libopagent.so* fails. This commit gets rid of this installation step when BR2_STATIC_LIBS=y. Fixes: http://autobuild.buildroot.net/results/2a6604622392a3f127fb61505e2751a88a90af7b/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/oprofile')
-rw-r--r--package/oprofile/oprofile.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index ba366403d..c73086e0c 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -47,6 +47,12 @@ endif
# a static build. We have to do the call to pkgconfig manually...
OPROFILE_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs popt`"
+ifeq ($(BR2_STATIC_LIBS),)
+define OPROFILE_INSTALL_SHARED_LIBRARY
+ $(INSTALL) -m 755 $(@D)/libopagent/.libs/*.so* $(TARGET_DIR)/usr/lib/oprofile
+endef
+endif
+
define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/share/oprofile
@@ -57,7 +63,7 @@ define OPROFILE_INSTALL_TARGET_CMDS
fi
$(INSTALL) -m 644 $(@D)/libregex/stl.pat $(TARGET_DIR)/usr/share/oprofile
$(INSTALL) -m 755 $(addprefix $(@D)/, $(OPROFILE_BINARIES)) $(TARGET_DIR)/usr/bin
- $(INSTALL) -m 755 $(@D)/libopagent/.libs/*.so* $(TARGET_DIR)/usr/lib/oprofile
+ $(OPROFILE_INSTALL_SHARED_LIBRARY)
endef
$(eval $(autotools-package))