summaryrefslogtreecommitdiff
path: root/package/owfs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-05 23:58:53 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-08 23:48:37 +0200
commiteef80855f1b4533467e04c8e776f1e2f826e5090 (patch)
treeb5f6db747c74631cb39ed4f561760538c4bd90db /package/owfs
parent225e1681cc000d904e5e98a3fcff974aac4e8d71 (diff)
owfs: disable PHP support
Since we upgraded PHP to PHP 7.x, the PHP support of OWFS started failing to build. Since we can hardly fix that on our own, the issue was reported upstream (https://sourceforge.net/p/owfs/support-requests/32/) and for now, we will disable PHP support in OWFS. Fixes: http://autobuild.buildroot.net/results/fe6843ec53fbed452d2e38a8577a235f73abb8db/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/owfs')
-rw-r--r--package/owfs/owfs.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/owfs/owfs.mk b/package/owfs/owfs.mk
index 0092603fb..83614afc7 100644
--- a/package/owfs/owfs.mk
+++ b/package/owfs/owfs.mk
@@ -17,6 +17,10 @@ OWFS_LICENSE = GPLv2+, LGPLv2 (owtcl)
OWFS_LICENSE_FILES = COPYING COPYING.LIB
OWFS_INSTALL_STAGING = YES
+# owfs PHP support is not PHP 7 compliant
+# https://sourceforge.net/p/owfs/support-requests/32/
+OWFS_CONF_OPTS += --disable-owphp --without-php
+
ifeq ($(BR2_PACKAGE_LIBFUSE),y)
OWFS_DEPENDENCIES += libfuse
OWFS_CONF_OPTS += \
@@ -49,13 +53,6 @@ else
OWFS_CONF_OPTS += --disable-avahi
endif
-ifeq ($(BR2_PACKAGE_PHP),y)
-OWFS_CONF_OPTS += --enable-owphp --with-php --with-phpconfig=$(STAGING_DIR)/usr/bin/php-config
-OWFS_DEPENDENCIES += php host-swig
-else
-OWFS_CONF_OPTS += --disable-owphp --without-php
-endif
-
# setup.py isn't python3 compliant
ifeq ($(BR2_PACKAGE_PYTHON),y)
OWFS_CONF_OPTS += \