summaryrefslogtreecommitdiff
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2014-06-30 11:51:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-15 22:45:21 +0200
commit67f25d1b212e71412fc4b239a33b79269a0c342c (patch)
tree56b7824bfe1edaf41e61e1d69afd757932fec5dc /package/pkg-generic.mk
parent762b14713e21214c4ed43af684888edb821f6a0b (diff)
infra: fix "<pkg>-rebuild" when using rsync source feature
Because the configure stamp file depends on the rsync stamp file, removing it by the "<pkg>-clean-for-rebuild" rule trigger the configure step. To avoid triggering the configure step use an order-only dependency. Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Reported-by: Cédric Marie <cedric.marie@openmailbox.org> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 2bd446603..395e593d2 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -545,7 +545,10 @@ else
# source, by rsyncing
# depends
# configure
-$$($(2)_TARGET_CONFIGURE): $$($(2)_TARGET_RSYNC)
+
+# Use an order-only dependency so the "<pkg>-clean-for-rebuild" rule
+# can remove the stamp file without triggering the configure step.
+$$($(2)_TARGET_CONFIGURE): | $$($(2)_TARGET_RSYNC)
$(1)-depends: $$($(2)_FINAL_DEPENDENCIES)