summaryrefslogtreecommitdiff
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-06-11 21:12:25 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-14 19:10:01 +0200
commit7742d073a434b07a72cdef5bf0eb81572e6c3a8c (patch)
tree6080f92927e4a999992315714f5b8ca7cae33a57 /package/pkg-generic.mk
parent54456cc6982598fa45e7c97609e83fabec7c1695 (diff)
infra: add comment describing single/double dollar-sign rules
As the rules with respect to variable and function references and the need for single or double dollar signs are not trivial, add a comment in pkg-generic.mk describing them. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 3821d3391..457d87366 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -269,6 +269,29 @@ endef
# argument 3 is the uppercase package name, without the HOST_ prefix
# for host packages
# argument 4 is the type (target or host)
+#
+# Note about variable and function references: inside all blocks that are
+# evaluated with $(eval), which includes all 'inner-xxx-package' blocks,
+# specific rules apply with respect to variable and function references.
+# - Numbered variables (parameters to the block) can be referenced with a single
+# dollar sign: $(1), $(2), $(3), etc.
+# - pkgdir and pkgname should be referenced with a single dollar sign too. These
+# functions rely on 'the most recently parsed makefile' which is supposed to
+# be the package .mk file. If we defer the evaluation of these functions using
+# double dollar signs, then they may be evaluated too late, when other
+# makefiles have already been parsed. One specific case is when $$(pkgdir) is
+# assigned to a variable using deferred evaluation with '=' and this variable
+# is used in a target rule outside the eval'ed inner block. In this case, the
+# pkgdir will be that of the last makefile parsed by buildroot, which is not
+# the expected value. This mechanism is for example used for the TARGET_PATCH
+# rule.
+# - All other variables should be referenced with a double dollar sign:
+# $$(TARGET_DIR), $$($(2)_VERSION), etc. Also all make functions should be
+# referenced with a double dollar sign: $$(subst), $$(call), $$(filter-out),
+# etc. This rule ensures that these variables and functions are only expanded
+# during the $(eval) step, and not earlier. Otherwise, unintuitive and
+# undesired behavior occurs with respect to these variables and functions.
+#
################################################################################
define inner-generic-package