summaryrefslogtreecommitdiff
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-07-14 13:50:25 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-15 19:18:25 +0200
commit358bf954452c095e5f782187ad7579e42d903df3 (patch)
treeb94889a1b5c18a356698a6914ba3be0c5ba478df /package/pkg-utils.mk
parent85a016f5e17100999de884dc48473e52b0b67389 (diff)
pkg-utils: kconfig helpers: add basic usage documentation
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 59a5ab2cc..e80286444 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -33,17 +33,17 @@ $(eval $(call caseconvert-helper,LOWERCASE,$(join $(addsuffix :,$([TO])),$([FROM
# package, and more.
#
-define KCONFIG_ENABLE_OPT
+define KCONFIG_ENABLE_OPT # (option, file)
$(SED) "/\\<$(1)\\>/d" $(2)
echo "$(1)=y" >> $(2)
endef
-define KCONFIG_SET_OPT
+define KCONFIG_SET_OPT # (option, value, file)
$(SED) "/\\<$(1)\\>/d" $(3)
echo "$(1)=$(2)" >> $(3)
endef
-define KCONFIG_DISABLE_OPT
+define KCONFIG_DISABLE_OPT # (option, file)
$(SED) "/\\<$(1)\\>/d" $(2)
echo "# $(1) is not set" >> $(2)
endef