summaryrefslogtreecommitdiff
path: root/package/poppler
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-03 15:41:12 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-05-03 16:33:46 +0200
commitbc8423a8d485283e1c5c44026d3777173afb469a (patch)
tree03a51066cb86d5f1ebb27b7ac0f395d6991ba253 /package/poppler
parenta500dff16875392b6ae91ab10e0595020b8289fd (diff)
poppler: add patch to fix invalid syntax in configure script
When configuring poppler, a shell error occurs: ./configure: line 19741: test: x: unary operator expected This is due to an invalid configure test, which is fixed by a newly added patch. We patch the configure script directly because poppler doesn't autoreconf properly. A patch on configure.ac has been submitted upstream so that hopefully we can drop our patch in a future release of poppler. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/poppler')
-rw-r--r--package/poppler/0001-Fix-invalid-shell-comparaison-in-libtiff-test.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/poppler/0001-Fix-invalid-shell-comparaison-in-libtiff-test.patch b/package/poppler/0001-Fix-invalid-shell-comparaison-in-libtiff-test.patch
new file mode 100644
index 000000000..f40bee1dd
--- /dev/null
+++ b/package/poppler/0001-Fix-invalid-shell-comparaison-in-libtiff-test.patch
@@ -0,0 +1,23 @@
+Fix syntax issue in configure script
+
+The change is not done in configure.ac, because the package doesn't
+autoreconf properly.
+
+Patch on configure.ac submitted upstream at
+https://bugs.freedesktop.org/show_bug.cgi?id=90292.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/configure
+===================================================================
+--- a/configure
++++ b/configure
+@@ -19738,7 +19738,7 @@
+ CXXFLAGS="$CXXFLAGS $LIBTIFF_CFLAGS"
+ LIBS="$LIBS $LIBTIFF_LIBS"
+ if test x$enable_libtiff = xyes; then
+- if test x"$LIBTIFF_LIBS" != ; then
++ if test x"$LIBTIFF_LIBS" != x; then
+ ac_fn_cxx_check_func "$LINENO" "TIFFOpen" "ac_cv_func_TIFFOpen"
+ if test "x$ac_cv_func_TIFFOpen" = xyes; then :
+