summaryrefslogtreecommitdiff
path: root/package/postgresql
diff options
context:
space:
mode:
authorPeter Seiderer <ps.report@gmx.net>2015-03-10 20:59:39 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-16 22:02:37 +0100
commit6f177dac73a289db28772fb3e20347aba5cd5e67 (patch)
treeb8535ae53755e19d29c5f9e6c66b7456bb0684ec /package/postgresql
parent7ebbf2e5c55fb11a7c828ffc7a93c9ef7a800c6b (diff)
postgresql: enable bfin compile
- overwrite platform support with linux template - disable spinlock support [Thomas: use the --with-template=linux option unconditionally.] Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/postgresql')
-rw-r--r--package/postgresql/postgresql.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/postgresql/postgresql.mk b/package/postgresql/postgresql.mk
index 7dc3f0bf0..d426093a3 100644
--- a/package/postgresql/postgresql.mk
+++ b/package/postgresql/postgresql.mk
@@ -13,6 +13,11 @@ POSTGRESQL_LICENSE_FILES = COPYRIGHT
POSTGRESQL_INSTALL_STAGING = YES
POSTGRESQL_CONFIG_SCRIPTS = pg_config
+# In most cases, postgresql configure script is able to guess the
+# platform, except for noMMU platforms that use the 'uclinux' host
+# qualifier, as is the case on Blackfin
+POSTGRESQL_CONF_OPTS = --with-template=linux
+
ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
# overwrite IPV6 detection
ifeq ($(BR2_INET_IPV6),y)
@@ -31,7 +36,7 @@ ifneq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
POSTGRESQL_CONF_OPTS += --disable-thread-safety
endif
-ifeq ($(BR2_microblazeel)$(BR2_microblazebe)$(BR2_nios2)$(BR2_xtensa),y)
+ifeq ($(BR2_bfin)$(BR2_microblazeel)$(BR2_microblazebe)$(BR2_nios2)$(BR2_xtensa),y)
POSTGRESQL_CONF_OPTS += --disable-spinlocks
endif