summaryrefslogtreecommitdiff
path: root/package/python-autobahn
diff options
context:
space:
mode:
authorMauro Condarelli <mc5686@mclink.it>2016-02-11 11:58:47 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-20 15:04:07 +0100
commit2b51d9ddf8160067c983212902151e0f48c1a7af (patch)
tree27b5bd182988c53fd9564704dfcde7cfc37e77d3 /package/python-autobahn
parentb3258b7535db3d6da8d6067e996982d3a7f98217 (diff)
python-autobahn: new package
Signed-off-by: Mauro Condarelli <mc5686@mclink.it> [Thomas: remove dependency on having .py files, since it builds fine and imports fine with .pyc files only.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-autobahn')
-rw-r--r--package/python-autobahn/Config.in9
-rw-r--r--package/python-autobahn/python-autobahn.hash3
-rw-r--r--package/python-autobahn/python-autobahn.mk14
3 files changed, 26 insertions, 0 deletions
diff --git a/package/python-autobahn/Config.in b/package/python-autobahn/Config.in
new file mode 100644
index 000000000..7e1429cdd
--- /dev/null
+++ b/package/python-autobahn/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_AUTOBAHN
+ bool "python-autobahn"
+ select BR2_PACKAGE_PYTHON_SIX # runtime
+ select BR2_PACKAGE_PYTHON_TXAIO # runtime
+ help
+ WebSocket client Hhh server library, WAMP real-time
+ framework.
+
+ https://pypi.python.org/pypi/autobahn
diff --git a/package/python-autobahn/python-autobahn.hash b/package/python-autobahn/python-autobahn.hash
new file mode 100644
index 000000000..8f55ac130
--- /dev/null
+++ b/package/python-autobahn/python-autobahn.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=b4b5445050749c1033b9b58f694f0c64, sha256 locally computed.
+md5 b4b5445050749c1033b9b58f694f0c64 autobahn-0.12.1.tar.gz
+sha256 664223879e159c88221f42d8d1ac6b8c4268d8b9316d8ab69a02761c5744cd79 autobahn-0.12.1.tar.gz
diff --git a/package/python-autobahn/python-autobahn.mk b/package/python-autobahn/python-autobahn.mk
new file mode 100644
index 000000000..1d0286712
--- /dev/null
+++ b/package/python-autobahn/python-autobahn.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-autobahn
+#
+################################################################################
+
+PYTHON_AUTOBAHN_VERSION = 0.12.1
+PYTHON_AUTOBAHN_SOURCE = autobahn-$(PYTHON_AUTOBAHN_VERSION).tar.gz
+PYTHON_AUTOBAHN_SITE = http://pypi.python.org/packages/source/a/autobahn
+PYTHON_AUTOBAHN_LICENSE = MIT
+PYTHON_AUTOBAHN_LICENSE_FILES = LICENSE
+PYTHON_AUTOBAHN_SETUP_TYPE = setuptools
+
+$(eval $(python-package))