summaryrefslogtreecommitdiff
path: root/package/python-django
diff options
context:
space:
mode:
authorOli Vogt <oli.vogt.pub01@gmail.com>2015-01-03 13:28:24 +1300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-04 22:04:35 +0100
commit71d6705ef6a3516325891bc117b3253b49ca0f5f (patch)
tree5d0f624001351e97bf2bb5e0ba556ed142b89775 /package/python-django
parentcac64f2b0cb9e6f6a39c7eede1b80152293a741a (diff)
python-django: new package
[Thomas: - Bump to Django 1.7.2, the latest available version; - Support Python 3 in addition to Python 2. - Use a download location from pypi.python.org since the download location from djangoproject.com didn't work as is and is impractical to use with Buildroot: the full URL of the tarball is https://www.djangoproject.com/download/1.7.2/tarball/. I.e, it does not end with the tarball file name.] Signed-off-by: oli vogt <oli.vogt.pub01@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-django')
-rw-r--r--package/python-django/Config.in16
-rw-r--r--package/python-django/python-django.hash2
-rw-r--r--package/python-django/python-django.mk15
3 files changed, 33 insertions, 0 deletions
diff --git a/package/python-django/Config.in b/package/python-django/Config.in
new file mode 100644
index 000000000..ff8422759
--- /dev/null
+++ b/package/python-django/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_PYTHON_DJANGO
+ bool "python-django"
+ select BR2_PACKAGE_PYTHON_UNICODEDATA if BR2_PACKAGE_PYTHON
+ select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON
+ select BR2_PACKAGE_PYTHON3_UNICODEDATA if BR2_PACKAGE_PYTHON3
+ select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3
+ help
+ Django is a high-level Python Web framework that encourages
+ rapid development and clean, pragmatic design. It takes your
+ Web applications from concept to launch in a matter of hours.
+ Django takes care of user authentication, content administration,
+ site maps, RSS feeds, user comments and many more tasks.
+ Django takes security seriously and helps developers avoid
+ many common security mistakes
+
+ https://www.djangoproject.com/
diff --git a/package/python-django/python-django.hash b/package/python-django/python-django.hash
new file mode 100644
index 000000000..0195a13b0
--- /dev/null
+++ b/package/python-django/python-django.hash
@@ -0,0 +1,2 @@
+# sha256 from https://www.djangoproject.com/m/pgp/Django-1.7.2.checksum.txt
+sha256 31c6c3c229f8c04b3be87e6afc3492903b57ec8f1188a47b6ae160d90cf653c8 Django-1.7.2.tar.gz
diff --git a/package/python-django/python-django.mk b/package/python-django/python-django.mk
new file mode 100644
index 000000000..5837088a4
--- /dev/null
+++ b/package/python-django/python-django.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-django
+#
+################################################################################
+
+PYTHON_DJANGO_VERSION = 1.7.2
+PYTHON_DJANGO_SOURCE = Django-$(PYTHON_DJANGO_VERSION).tar.gz
+# The official Django site has an unpractical URL
+PYTHON_DJANGO_SITE = https://pypi.python.org/packages/source/D/Django/
+PYTHON_DJANGO_LICENSE = BSD
+PYTHON_DJANGO_LICENSE_FILES = LICENSE
+PYTHON_DJANGO_SETUP_TYPE = setuptools
+
+$(eval $(python-package))