summaryrefslogtreecommitdiff
path: root/package/python-libconfig
diff options
context:
space:
mode:
authorJohan Derycke <johanderycke@gmail.com>2014-03-10 09:38:49 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-29 18:26:19 +0100
commit9523bdfddfab849bef143db493a052df863de44f (patch)
tree38972577fa404fe27b8938eadbe9e97acdeb9b10 /package/python-libconfig
parent3b44149a2251081d9180651ae5f8a184705e3835 (diff)
python-libconfig: new package
Python bindings to the C++ library libconfig https://github.com/cnangel/python-libconfig Signed-off-by: Johan Derycke <johan.derycke@barco.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-libconfig')
-rw-r--r--package/python-libconfig/Config.in22
-rw-r--r--package/python-libconfig/python-libconfig.mk17
2 files changed, 39 insertions, 0 deletions
diff --git a/package/python-libconfig/Config.in b/package/python-libconfig/Config.in
new file mode 100644
index 000000000..eae6cdafc
--- /dev/null
+++ b/package/python-libconfig/Config.in
@@ -0,0 +1,22 @@
+comment "python-libconfig needs a toolchain w/ C++, largefile, threads"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
+
+config BR2_PACKAGE_PYTHON_LIBCONFIG
+ bool "python-libconfig"
+ depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
+ select BR2_PACKAGE_BOOST
+ select BR2_PACKAGE_BOOST_PYTHON
+ select BR2_PACKAGE_LIBCONFIG
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_LARGEFILE
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ Python bindings to the C++ library libconfig
+
+ Libconfig is a simple library for manipulating structured
+ configuration files. The file format is more compact and more
+ readable than XML. And unlike XML, it is type-aware, so it is
+ not necessary to do string parsing in application code.
+ http://www.hyperrealm.com/libconfig/
+
+ https://github.com/cnangel/python-libconfig
diff --git a/package/python-libconfig/python-libconfig.mk b/package/python-libconfig/python-libconfig.mk
new file mode 100644
index 000000000..3f5984b66
--- /dev/null
+++ b/package/python-libconfig/python-libconfig.mk
@@ -0,0 +1,17 @@
+################################################################################
+#
+# python-libconfig
+#
+################################################################################
+
+PYTHON_LIBCONFIG_VERSION = b271c3d9dac938ad5cd29b67bd08cc5536a5a391
+PYTHON_LIBCONFIG_SITE = $(call github,cnangel,python-libconfig,$(PYTHON_LIBCONFIG_VERSION))
+
+PYTHON_LIBCONFIG_LICENSE = BSD
+PYTHON_LIBCONFIG_LICENSE_FILES = README
+
+PYTHON_LIBCONFIG_SETUP_TYPE = setuptools
+
+PYTHON_LIBCONFIG_DEPENDENCIES = libconfig boost
+
+$(eval $(python-package))