summaryrefslogtreecommitdiff
path: root/package/python-sip
diff options
context:
space:
mode:
authorManuel Vögele <develop@manuel-voegele.de>2016-08-19 15:42:24 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-19 15:58:10 +0200
commita9ca6963095ee64f0be943a34a972f024fa0e893 (patch)
tree636b5d5731229797016173f7ce5668d06632b5d4 /package/python-sip
parente73a1db4646c2d6696c529b7bdd2b59d54ff460a (diff)
python-sip: allow package to be built using Qt5
Signed-off-by: Manuel Vögele <develop@manuel-voegele.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-sip')
-rw-r--r--package/python-sip/Config.in7
-rw-r--r--package/python-sip/python-sip.mk4
2 files changed, 10 insertions, 1 deletions
diff --git a/package/python-sip/Config.in b/package/python-sip/Config.in
index 45e48ad00..1f8961d0d 100644
--- a/package/python-sip/Config.in
+++ b/package/python-sip/Config.in
@@ -2,12 +2,17 @@ comment "python-sip needs a toolchain w/ C++, threads"
depends on BR2_USE_MMU
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
+comment "python-sip needs qt or qt5"
+ depends on BR2_USE_MMU
+ depends on BR2_INSTALL_LIBSTDCPP && BR2_TOOLCHAIN_HAS_THREADS
+ depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
+
config BR2_PACKAGE_PYTHON_SIP
bool "python-sip"
depends on BR2_INSTALL_LIBSTDCPP # qt
depends on BR2_TOOLCHAIN_HAS_THREADS # qt
depends on BR2_USE_MMU # qt
- select BR2_PACKAGE_QT
+ depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
help
SIP is a tool that makes it very easy to create Python
bindings for C and C++ libraries. It was originally
diff --git a/package/python-sip/python-sip.mk b/package/python-sip/python-sip.mk
index d13801fb8..0c0a94738 100644
--- a/package/python-sip/python-sip.mk
+++ b/package/python-sip/python-sip.mk
@@ -10,7 +10,11 @@ PYTHON_SIP_SITE = http://downloads.sourceforge.net/project/pyqt/sip/sip-$(PYTHON
PYTHON_SIP_LICENSE = SIP license or GPLv2 or GPLv3
PYTHON_SIP_LICENSE_FILES = LICENSE LICENSE-GPL2 LICENSE-GPL3
+ifeq ($(BR2_PACKAGE_QT5),y)
+PYTHON_SIP_DEPENDENCIES = qt5base
+else
PYTHON_SIP_DEPENDENCIES = qt
+endif
ifeq ($(BR2_PACKAGE_PYTHON),y)
PYTHON_SIP_DEPENDENCIES += python