summaryrefslogtreecommitdiff
path: root/package/python/108-optional-nis.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-28 21:54:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-02 19:30:25 +0100
commit897d07c313104ddb54fcf9c538acb0ca65e1a687 (patch)
tree6a92eaeced471ff0029b54d00b86ede1c8c4a18f /package/python/108-optional-nis.patch
parent9badea2d058a75182f2a37bbefa0aaf48020575d (diff)
python: rename patches to the new convention
Note that we don't use completely sequential numbers, because patches below 100 are used to address cross-compilation issues in Python, while patches above 100 are used to make more Python modules configurable. [Thomas: fixup commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/python/108-optional-nis.patch')
-rw-r--r--package/python/108-optional-nis.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/python/108-optional-nis.patch b/package/python/108-optional-nis.patch
new file mode 100644
index 000000000..f07bbb610
--- /dev/null
+++ b/package/python/108-optional-nis.patch
@@ -0,0 +1,28 @@
+Add an option to disable NIS
+
+NIS is not necessarily available in uClibc, so we need an option to
+not compile support for it.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ configure.in | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -2650,6 +2650,12 @@
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk"
+ fi])
+
++AC_ARG_ENABLE(nis,
++ AS_HELP_STRING([--disable-nis], [disable NIS]),
++ [ if test "$enableval" = "no"; then
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
++ fi])
++
+ AC_SUBST(TK)
+ AC_ARG_ENABLE(tk,
+ AS_HELP_STRING([--disable-tk], [disable tk]),