summaryrefslogtreecommitdiff
path: root/package/rng-tools
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-11-26 16:01:18 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-11-26 22:27:18 +0100
commit4e987b1cd482b4a6c5c953f71674cfd1e9592279 (patch)
tree2fb7b3c103d3f4b8b28208186b38a8d72a38f321 /package/rng-tools
parent1144059ede54f9908f3e5cb6b41b395efb6855d9 (diff)
rng-tools: bump to version 5
Add semi-automatic libgcrypt dependency for i386/x86_64 to use RDRAND. This is exclusively used by rngd for which we don't yet ship an initscript/service file. Even so the user can choose to disable it at invocation time via the --no-drng option (which must be accounted for). Also add hash file. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/rng-tools')
-rw-r--r--package/rng-tools/Config.in2
-rw-r--r--package/rng-tools/rng-tools.hash3
-rw-r--r--package/rng-tools/rng-tools.mk18
3 files changed, 18 insertions, 5 deletions
diff --git a/package/rng-tools/Config.in b/package/rng-tools/Config.in
index c50a8c084..43c5a1c2e 100644
--- a/package/rng-tools/Config.in
+++ b/package/rng-tools/Config.in
@@ -1,6 +1,8 @@
config BR2_PACKAGE_RNG_TOOLS
bool "rng-tools"
select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+ # For rdrand ligcrypt is required and it's not obvious to users
+ select BR2_PACKAGE_LIBGCRYPT if BR2_i386 || BR2_x86_64
help
Daemon to use hardware random number generators.
diff --git a/package/rng-tools/rng-tools.hash b/package/rng-tools/rng-tools.hash
new file mode 100644
index 000000000..09769e462
--- /dev/null
+++ b/package/rng-tools/rng-tools.hash
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/gkernel/files/rng-tools/5/
+md5 6726cdc6fae1f5122463f24ae980dd68 rng-tools-5.tar.gz
+sha1 3092768ac45315a5dcc0170d05566d1d00dbad96 rng-tools-5.tar.gz
diff --git a/package/rng-tools/rng-tools.mk b/package/rng-tools/rng-tools.mk
index 56858e7ea..5b89656e0 100644
--- a/package/rng-tools/rng-tools.mk
+++ b/package/rng-tools/rng-tools.mk
@@ -4,13 +4,21 @@
#
################################################################################
-RNG_TOOLS_VERSION = 4
+RNG_TOOLS_VERSION = 5
RNG_TOOLS_SITE = http://downloads.sourceforge.net/project/gkernel/rng-tools/$(RNG_TOOLS_VERSION)
-ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
-RNG_TOOLS_CONF_ENV = LIBS="-largp"
-RNG_TOOLS_DEPENDENCIES = argp-standalone
-endif
RNG_TOOLS_LICENSE = GPLv2
RNG_TOOLS_LICENSE_FILES = COPYING
+# Work around for uClibc's lack of argp_*() functions
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+RNG_TOOLS_CONF_ENV += LIBS="-largp"
+RNG_TOOLS_DEPENDENCIES += argp-standalone
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+RNG_TOOLS_DEPENDENCIES += libgcrypt
+else
+RNG_TOOLS_CONF_OPTS += --without-libgcrypt
+endif
+
$(eval $(autotools-package))