summaryrefslogtreecommitdiff
path: root/package/rpi-userland/rpi-userland.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-10-06 00:17:17 +0200
committerPeter Korsgaard <peter@korsgaard.com>2013-10-06 20:47:22 +0200
commit19b4a6f4e08fdf7b698e4be735328cb69c40020d (patch)
treef0504e8ba187dc9df900ea23410b134772857d6f /package/rpi-userland/rpi-userland.mk
parent1980bf056e16c604c1f33ce9771d725da096cfe7 (diff)
pakage/rpi-userland: add and install our bcm_host.pc
This allows pkg-config-aware packages to include headers from, and link against Broadcom VideoCore host API library. bcm_host.pc copied almost as-is from: http://cgit.collabora.com/git/user/pq/android-pc-files.git/tree/pkgconfig?h=raspberrypi with only a fix to the prefix (we're using /usr). [Peter: s/TARGET/STAGING/] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/rpi-userland/rpi-userland.mk')
-rw-r--r--package/rpi-userland/rpi-userland.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/rpi-userland/rpi-userland.mk b/package/rpi-userland/rpi-userland.mk
index c3ea43a9f..cc032bfcd 100644
--- a/package/rpi-userland/rpi-userland.mk
+++ b/package/rpi-userland/rpi-userland.mk
@@ -14,7 +14,12 @@ RPI_USERLAND_CONF_OPT = -DVMCS_INSTALL_PREFIX=/usr
define RPI_USERLAND_POST_TARGET_CLEANUP
rm -Rf $(TARGET_DIR)/usr/src
endef
-
RPI_USERLAND_POST_INSTALL_TARGET_HOOKS += RPI_USERLAND_POST_TARGET_CLEANUP
+define RPI_USERLAND_POST_STAGING_PC_FILE
+ install -D -m 0644 package/rpi-userland/bcm_host.pc \
+ $(STAGING_DIR)/usr/lib/pkgconfig/bcm_host.pc
+endef
+RPI_USERLAND_POST_INSTALL_STAGING_HOOKS += RPI_USERLAND_POST_STAGING_PC_FILE
+
$(eval $(cmake-package))