summaryrefslogtreecommitdiff
path: root/package/ruby
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-09-06 15:59:27 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-06 22:12:37 +0200
commit9a9d64bb496215a8dfbfe23960141ee7bf86c203 (patch)
tree2526f2356502da8cc440b766c13780341794f49f /package/ruby
parent033d865dabcaec3dedfb81d3433a44c4dbe21422 (diff)
ruby: add support for gmp as an optional dependency
Ruby can now use gmp optionally, so make sure that if the gmp package for the target is enabled, it gets built before the ruby package, and the appropriate configure options are passed to Ruby. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ruby')
-rw-r--r--package/ruby/ruby.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/ruby/ruby.mk b/package/ruby/ruby.mk
index 384cc88d5..8c094b5cc 100644
--- a/package/ruby/ruby.mk
+++ b/package/ruby/ruby.mk
@@ -54,6 +54,12 @@ endif
ifeq ($(BR2_PACKAGE_ZLIB),y)
RUBY_DEPENDENCIES += zlib
endif
+ifeq ($(BR2_PACKAGE_GMP),y)
+ RUBY_DEPENDENCIES += gmp
+ RUBY_CONF_OPT += --with-gmp
+else
+ RUBY_CONF_OPT += --without-gmp
+endif
# Remove rubygems and friends, as they need extensions that aren't
# built and a target compiler.