summaryrefslogtreecommitdiff
path: root/package/samba4
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-03-06 09:50:29 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-06 23:50:17 +0100
commit6c47da8e7f8f79d1bfa5447f4306173a4cb4ee75 (patch)
tree143db74c95c3d7ab4fab7c29ee76ce32388169e7 /package/samba4
parent62dc087f9f4b02feb2b5a5504dfedeac31965029 (diff)
samba4: install to staging
It's required for packages that need libsmbclient. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/samba4')
-rw-r--r--package/samba4/samba4.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/samba4/samba4.mk b/package/samba4/samba4.mk
index 527d584f1..78d92ef39 100644
--- a/package/samba4/samba4.mk
+++ b/package/samba4/samba4.mk
@@ -7,6 +7,7 @@
SAMBA4_VERSION = 4.2.0
SAMBA4_SITE = http://ftp.samba.org/pub/samba
SAMBA4_SOURCE = samba-$(SAMBA4_VERSION).tar.gz
+SAMBA4_INSTALL_STAGING = YES
SAMBA4_LICENSE = GPLv3+
SAMBA4_LICENSE_FILES = COPYING
SAMBA4_DEPENDENCIES = host-e2fsprogs host-heimdal e2fsprogs popt python zlib \
@@ -113,6 +114,10 @@ define SAMBA4_BUILD_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
endef
+define SAMBA4_INSTALL_STAGING_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) install
+endef
+
define SAMBA4_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
endef