summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-12-03 13:17:35 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-04 16:22:08 +0100
commit06d8abd0908524d6623958612e5ba8093ab5d921 (patch)
treeefab57acda703c5d15f1de1519f5e8b6f2d476df /package
parent280bb6807619e2e858836435f44aad0cccd27a40 (diff)
package/aubio: add libsndfile optional dependency
Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/aubio/aubio.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/aubio/aubio.mk b/package/aubio/aubio.mk
index aa4ddd0fc..e1694ab64 100644
--- a/package/aubio/aubio.mk
+++ b/package/aubio/aubio.mk
@@ -16,9 +16,15 @@ AUBIO_CONF_OPTS = \
--disable-atlas \
--disable-samplerate \
--disable-avcodec \
- --disable-sndfile \
--disable-jack \
--disable-fftw3 \
--disable-fftw3f
+ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
+AUBIO_DEPENDENCIES += libsndfile
+AUBIO_CONF_OPTS += --enable-sndfile
+else
+AUBIO_CONF_OPTS += --disable-sndfile
+endif
+
$(eval $(waf-package))