summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2015-09-02 19:54:12 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-02 20:07:51 +0100
commit0ac0982fb7e936c48c0925b272eb18e0195e1c47 (patch)
tree5efd84462c7e2d7d6aa14210eaf475ecbdefec27 /package
parent6d5d7b33945c343a12f1c8c12f1cd360e2897823 (diff)
imx-vpu: remove kernel dependency
The imx-vpu package builds just fine without any special kernel header. Cc: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Tested-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/freescale-imx/imx-vpu/Config.in5
-rw-r--r--package/freescale-imx/imx-vpu/imx-vpu.mk5
2 files changed, 1 insertions, 9 deletions
diff --git a/package/freescale-imx/imx-vpu/Config.in b/package/freescale-imx/imx-vpu/Config.in
index 8a9541607..220385cec 100644
--- a/package/freescale-imx/imx-vpu/Config.in
+++ b/package/freescale-imx/imx-vpu/Config.in
@@ -1,6 +1,5 @@
config BR2_PACKAGE_IMX_VPU
bool "imx-vpu"
- depends on BR2_LINUX_KERNEL
depends on BR2_arm # Only relevant for i.MX
select BR2_PACKAGE_FIRMWARE_IMX
help
@@ -11,7 +10,3 @@ config BR2_PACKAGE_IMX_VPU
This library is provided by Freescale as-is and doesn't have
an upstream.
-
-comment "imx-vpu needs an imx-specific Linux kernel to be built"
- depends on BR2_arm
- depends on !BR2_LINUX_KERNEL
diff --git a/package/freescale-imx/imx-vpu/imx-vpu.mk b/package/freescale-imx/imx-vpu/imx-vpu.mk
index 4c4a03111..599dce85c 100644
--- a/package/freescale-imx/imx-vpu/imx-vpu.mk
+++ b/package/freescale-imx/imx-vpu/imx-vpu.mk
@@ -10,14 +10,11 @@ IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin
IMX_VPU_INSTALL_STAGING = YES
-# imx-vpu needs access to imx-specific kernel headers
-IMX_VPU_DEPENDENCIES += linux
IMX_VPU_MAKE_ENV = \
$(TARGET_MAKE_ENV) \
$(TARGET_CONFIGURE_OPTS) \
CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
- PLATFORM=$(BR2_PACKAGE_FREESCALE_IMX_PLATFORM) \
- INCLUDE="-idirafter $(LINUX_DIR)/include"
+ PLATFORM=$(BR2_PACKAGE_FREESCALE_IMX_PLATFORM)
IMX_VPU_LICENSE = Freescale Semiconductor Software License Agreement
IMX_VPU_LICENSE_FILES = EULA vpu/EULA.txt