summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-04 22:44:56 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-04 22:49:15 +0100
commit1120fdc379440b23063b0d083b1d3592e6a086a3 (patch)
treece0a10b2cc7d0e09c1c07320663b961550a867d3 /package
parent3e123c55d65db52b9cc2b46cd498c829d28f0457 (diff)
erlang: odbc support requires thread support
Fixes: http://autobuild.buildroot.net/results/cba60679fa916128796a7b4131ed50403bc74798/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/erlang/erlang.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/erlang/erlang.mk b/package/erlang/erlang.mk
index c9d7b2267..3200c388f 100644
--- a/package/erlang/erlang.mk
+++ b/package/erlang/erlang.mk
@@ -55,8 +55,12 @@ else
ERLANG_CONF_OPTS += --without-ssl
endif
-ifeq ($(BR2_PACKAGE_UNIXODBC),y)
+# ODBC support in erlang requires threads
+ifeq ($(BR2_PACKAGE_UNIXODBC)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
ERLANG_DEPENDENCIES += unixodbc
+ERLANG_CONF_OPTS += --with-odbc
+else
+ERLANG_CONF_OPTS += --without-odbc
endif
ifeq ($(BR2_PACKAGE_ZLIB),y)