summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2015-10-01 14:23:57 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-10-03 23:14:27 +0200
commit1180bafd8e1de2b12db3c7c235b128c9e48d4abb (patch)
treedb3bcda8b3facf4e5231fb9e23e1b2b0d1893436 /package
parentc263cefe86c622ec4821ac72df63ef3a6bf6ac01 (diff)
gdb: do not build documentation for bfd and gprof
Our previous patch to disable the documentation in gdb wasn't complete. There are cases where the documentation under bfd and gprof directories is being built, causing the subsequent failure due to missing makeinfo. This patch fixes that problem. Fixes: http://autobuild.buildroot.org/results/244/2442e697d8a300496434fd42fcb1ee3941d13e06/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package')
-rw-r--r--package/gdb/gdb.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 58a12323d..15f394ce1 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -54,6 +54,12 @@ endif
# Prevent gdb to build the documentation
define GDB_DISABLE_DOC
$(SED) '/^SUBDIRS =/ s/doc//' $(@D)/gdb/Makefile.in
+ if test -e $(@D)/bfd/doc/Makefile.in ; then \
+ $(SED) 's/^INFO_DEPS =.*$$/INFO_DEPS =/' $(@D)/bfd/doc/Makefile.in ; \
+ fi
+ if test -e $(@D)/gprof/Makefile.in ; then \
+ $(SED) 's/^INFO_DEPS =.*$$/INFO_DEPS =/' $(@D)/gprof/Makefile.in ; \
+ fi
endef
GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC
HOST_GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC