summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-05-21 13:47:44 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-05-26 12:13:38 +0200
commit2b9d07fb5d4c334d14966e1ee599d7fcbb42fdeb (patch)
tree6d09427e32c842a46321d3c8ff5f00ddc54190cf /package
parentf1a3e0cb1be043bb8efe91a415615440f7ba94a4 (diff)
python2: Fix disabling module bsddb
Using this minimal defconfig BR2_TOOLCHAIN_EXTERNAL=y BR2_PACKAGE_PYTHON=y BR2_PACKAGE_BERKELEYDB=y the current code does not prevent the build of output/build/python-2.7.6/Modules/_bsddb.o because the module is really called _bsddb, see python-2.7.6/Modules/_bsddb.c, line 9604. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package')
-rw-r--r--package/python/python-110-optional-db.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/python/python-110-optional-db.patch b/package/python/python-110-optional-db.patch
index ea756daa8..a3e5fe8ef 100644
--- a/package/python/python-110-optional-db.patch
+++ b/package/python/python-110-optional-db.patch
@@ -70,7 +70,7 @@ Index: b/configure.ac
+ AS_HELP_STRING([--disable-bsddb], [disable BerkeyleyDB]),
+ [ if test "$enableval" = "no"; then
+ BSDDB=no
-+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bsddb"
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _bsddb"
+ else
+ BSDDB=yes
+ fi], [ BSDDB=yes ])