summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-11-08 23:18:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-09 23:28:29 +0100
commit527e63cb82bae97ac2ef48a32a8d0c559ed9701b (patch)
tree7b4a1d0465e6604b1fd825914c49cf958ba90b07 /package
parent179c5f1b87a46ac272d66a947fddbf7c0fdeb442 (diff)
package/pseudo: force rpath and pass our host CFLAGS
pseudo whines when those are not set, and tries to find a suitable value; this is usually correct but risk an incorrect guess in corner cases. Rather than leaving those in guess-mode, just force them to values we know are correct. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gaƫl PORTAY <gael.portay@savoirfairelinux.com> Cc: Patrick Keroulas <patrick.keroulas@savoirfairelinux.com> Cc: Erico Nunes <nunes.erico@gmail.com> Cc: Julien BOIBESSOT <julien.boibessot@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Reviewed-by: Arnout Vandecappelle <arnout@mind.be> [Thomas: use double quotes instead of single quotes.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/pseudo/pseudo.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/pseudo/pseudo.mk b/package/pseudo/pseudo.mk
index 92de2c6f1..a924e10c4 100644
--- a/package/pseudo/pseudo.mk
+++ b/package/pseudo/pseudo.mk
@@ -16,7 +16,12 @@ HOST_PSEUDO_DEPENDENCIES = host-attr host-sqlite
# configure script is not generated by autoconf, so passing --libdir
# is necessary, even if the infrastructure passes --prefix already.
+# It also does not use CFLAGS from the environment, they need to be
+# specified with a custom --cflags option. Also force rpath to avoid
+# a warning at configure time.
HOST_PSEUDO_CONF_OPTS = \
+ --cflags="$(HOSTCFLAGS)" \
+ --with-rpath=$(HOST_DIR)/usr/lib \
--bits=$(if $(filter %64,$(HOSTARCH)),64,32) \
--libdir=$(HOST_DIR)/usr/lib \
--with-sqlite=$(HOST_DIR)/usr