summaryrefslogtreecommitdiff
path: root/toolchain/toolchain
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-06-11 21:12:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-14 19:10:13 +0200
commit9a8ec9195c4f035dfb315267c2da92cc4b6e96a3 (patch)
treeac72c1c4fc5278f2c07924639eb92a376fb2bb0d /toolchain/toolchain
parentf6fc9abd10ea00df53dcaea0083063a1e3433150 (diff)
toolchain/toolchain-buildroot: migrate to virtual package infrastructure
This patch migrates the toolchain and toolchain-buildroot packages to the virtual package infrastructure, causing the log messages to change from: >>> toolchain undefined Downloading >>> toolchain undefined Extracting ... to >>> toolchain virtual Downloading >>> toolchain virtual Extracting ... and similar for 'toolchain-buildroot', simply because it looks nicer. At the same time, the directory names also become toolchain-virtual, toolchain-buildroot-virtual instead of the corresponding 'undefined' variants. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/toolchain')
-rw-r--r--toolchain/toolchain/toolchain.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/toolchain/toolchain/toolchain.mk b/toolchain/toolchain/toolchain.mk
index 7241fe786..c22713bfe 100644
--- a/toolchain/toolchain/toolchain.mk
+++ b/toolchain/toolchain/toolchain.mk
@@ -4,8 +4,6 @@
#
################################################################################
-TOOLCHAIN_SOURCE =
-
ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
TOOLCHAIN_DEPENDENCIES += toolchain-buildroot
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
@@ -14,6 +12,6 @@ endif
TOOLCHAIN_ADD_TOOLCHAIN_DEPENDENCY = NO
-$(eval $(generic-package))
+$(eval $(virtual-package))
toolchain: $(HOST_DIR)/usr/share/buildroot/toolchainfile.cmake