summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-11-21 17:36:16 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-18 22:57:16 +0100
commitc785b1b2c4dc51f24f72a82b1d36a8180c220d90 (patch)
tree28b1c4888ac5d2d72276501688d7b5eda97072b2 /toolchain
parent09f1a3b9ebd380b42fb63f83dd43d9c9bf7b3370 (diff)
toolchain-external: CodeSourcery NIOSII: support only one version
See the conclusion about external toolchains during the Buildroot meeting [1]: "In the future, we stick to a single external toolchain version. The Kconfig symbol should not encode the version (avoid legacy handling)" [1] http://elinux.org/index.php?title=Buildroot:DeveloperDaysELCE2015#Report Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/Config.in21
-rw-r--r--toolchain/toolchain-external/toolchain-external.hash1
-rw-r--r--toolchain/toolchain-external/toolchain-external.mk18
3 files changed, 3 insertions, 37 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 523e773f6..6424a8f63 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -501,7 +501,7 @@ comment "Sourcery CodeBench toolchains are only available for MIPS/MIPS64 o32 an
depends on BR2_MIPS_NABI32
depends on !BR2_STATIC_LIBS
-config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
bool "Sourcery CodeBench Nios-II 2014.05"
depends on BR2_nios2
depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -517,22 +517,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
from Mentor Graphics. It uses gcc 4.8.3, binutils 2.24.51,
glibc 2.19.90, gdb 7.7.50 and kernel headers 3.12.
-config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- bool "Sourcery CodeBench Nios-II 2013.05"
- depends on BR2_nios2
- depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
- depends on !BR2_STATIC_LIBS
- select BR2_TOOLCHAIN_EXTERNAL_GLIBC
- select BR2_TOOLCHAIN_HAS_NATIVE_RPC
- select BR2_INSTALL_LIBSTDCPP
- select BR2_HOSTARCH_NEEDS_IA32_LIBS
- select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_7
- select BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
- help
- Sourcery CodeBench toolchain for the Nios-II architecture,
- from Mentor Graphics. It uses gcc 4.7.3, binutils 2.23.52,
- glibc 2.17, gdb 7.4.50 and kernel headers 3.7.0.
-
config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201203
bool "Sourcery CodeBench PowerPC 2012.03"
depends on BR2_powerpc
@@ -990,8 +974,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
default "mips-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201405
default "mips-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201411
default "mips-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201505
- default "nios2-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- default "nios2-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ default "nios2-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
default "powerpc-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009
default "powerpc-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103
default "powerpc-mentor-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201203
diff --git a/toolchain/toolchain-external/toolchain-external.hash b/toolchain/toolchain-external/toolchain-external.hash
index 8a3e85b31..dd95adea3 100644
--- a/toolchain/toolchain-external/toolchain-external.hash
+++ b/toolchain/toolchain-external/toolchain-external.hash
@@ -23,7 +23,6 @@ sha256 395f1c504a8fb6b7a10663143627b7eee2edc8fd884aa13c4b8505a3623960f5 arm-201
sha256 8455854d3b3abbc2328e6c061c6b9625ef8f9c1f236db9f1771877715bd70b9b arm-2013.11-33-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
sha256 39ee0e789034334ecc89af94e838e3a4815400ac5ff980f808f466b04778532e arm-2014.05-29-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
# NiosII
-sha256 29567361910b020751ea8041ecb45b3cc74714e71c6deb4981b678772b746b33 sourceryg++-2013.05-43-nios2-linux-gnu-i686-pc-linux-gnu.tar.bz2
sha256 fb02fe3d595bd80a6e0ebc9d59a64010d84ae8d13f47e241b3a335f42b0414dc sourceryg++-2014.05-47-nios2-linux-gnu-i686-pc-linux-gnu.tar.bz2
# PowerPC
sha256 d68d1a2a055ece3824a1a11fcc0a8e813ee1d215025247cce0d877caa12c4b54 freescale-2010.09-55-powerpc-linux-gnu-i686-pc-linux-gnu.tar.bz2
diff --git a/toolchain/toolchain-external/toolchain-external.mk b/toolchain/toolchain-external/toolchain-external.mk
index 8e85799b4..0c0581f37 100644
--- a/toolchain/toolchain-external/toolchain-external.mk
+++ b/toolchain/toolchain-external/toolchain-external.mk
@@ -358,11 +358,7 @@ else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201505),y)
TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu
TOOLCHAIN_EXTERNAL_SOURCE = mips-2015.05-18-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201505_LIB_NAMES_FIX
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305),y)
-TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/nios2-linux-gnu
-TOOLCHAIN_EXTERNAL_SOURCE = sourceryg++-2013.05-43-nios2-linux-gnu-i686-pc-linux-gnu.tar.bz2
-TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_SANITIZE_KERNEL_HEADERS
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405),y)
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII),y)
TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/nios2-linux-gnu
TOOLCHAIN_EXTERNAL_SOURCE = sourceryg++-2014.05-47-nios2-linux-gnu-i686-pc-linux-gnu.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009),y)
@@ -764,18 +760,6 @@ define TOOLCHAIN_EXTERNAL_INSTALL_WRAPPER
done
endef
-# This sed magic is taken from Linux headers_install.sh script.
-define TOOLCHAIN_EXTERNAL_SANITIZE_KERNEL_HEADERS
- $(Q)$(call MESSAGE,"Sanitizing kernel headers")
- find $(STAGING_DIR)/usr/include/linux/ -name "*.h" | xargs sed -r -i \
- -e 's/([ \t(])(__user|__force|__iomem)[ \t]/\1/g' \
- -e 's/__attribute_const__([ \t]|$$)/\1/g' \
- -e 's@^#include <linux/compiler.h>@@' \
- -e 's/(^|[^a-zA-Z0-9])__packed([^a-zA-Z0-9_]|$$)/\1__attribute__((packed))\2/g' \
- -e 's/(^|[ \t(])(inline|asm|volatile)([ \t(]|$$)/\1__\2__\3/g' \
- -e 's@#(ifndef|define|endif[ \t]*/[*])[ \t]*_UAPI@#\1 @'
-endef
-
#
# Generate gdbinit file for use with Buildroot
#