summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/libraw/libraw.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/libraw/libraw.mk b/package/libraw/libraw.mk
index 5ebc4a2de..03f09f96f 100644
--- a/package/libraw/libraw.mk
+++ b/package/libraw/libraw.mk
@@ -12,7 +12,6 @@ LIBRAW_INSTALL_STAGING = YES
LIBRAW_AUTORECONF = YES
LIBRAW_CONF_OPTS += \
--disable-examples \
- --disable-lcms \
--disable-openmp \
--disable-demosaic-pack-gpl2 \
--disable-demosaic-pack-gpl3
@@ -33,4 +32,11 @@ else
LIBRAW_CONF_OPTS += --disable-jpeg
endif
+ifeq ($(BR2_PACKAGE_LCMS2),y)
+LIBRAW_CONF_OPTS += --enable-lcms
+LIBRAW_DEPENDENCIES += lcms2 host-pkgconf
+else
+LIBRAW_CONF_OPTS += --disable-lcms
+endif
+
$(eval $(autotools-package))