summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/gdb/gdb.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 1e23e5a36..1c778e909 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -68,6 +68,13 @@ GDB_DISABLE_BINUTILS_CONF_OPTS = \
--disable-ld \
--disable-gas
+# Starting with gdb 7.11, the bundled gnulib tries to use
+# rpl_gettimeofday (gettimeofday replacement) due to the code being
+# unable to determine if the replacement function should be used or
+# not when cross-compiling with uClibc or musl as C libraries. So use
+# gl_cv_func_gettimeofday_clobber=no to not use rpl_gettimeofday,
+# assuming musl and uClibc have a properly working gettimeofday
+# implementation.
GDB_CONF_ENV = \
ac_cv_type_uintptr_t=yes \
gt_cv_func_gettext_libintl=yes \
@@ -77,7 +84,8 @@ GDB_CONF_ENV = \
bash_cv_must_reinstall_sighandlers=no \
bash_cv_func_sigsetjmp=present \
bash_cv_have_mbstate_t=yes \
- gdb_cv_func_sigsetjmp=yes
+ gdb_cv_func_sigsetjmp=yes \
+ gl_cv_func_gettimeofday_clobber=no
# The shared only build is not supported by gdb, so enable static build for
# build-in libraries with --enable-static.