summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/rpm/rpm.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/rpm/rpm.mk b/package/rpm/rpm.mk
index 68d964afc..fda10f224 100644
--- a/package/rpm/rpm.mk
+++ b/package/rpm/rpm.mk
@@ -46,7 +46,10 @@ endif
# xz payload support needs a toolchain w/ C++
ifeq ($(BR2_PACKAGE_XZ)$(BR2_INSTALL_LIBSTDCPP),yy)
-RPM_CONF_OPTS += --with-xz
+RPM_DEPENDENCIES += xz
+RPM_CONF_OPTS += --with-xz=external
+else
+RPM_CONF_OPTS += --with-xz=none
endif
ifeq ($(BR2_PACKAGE_BZIP2),y)