summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/gdb/Config.in16
-rw-r--r--package/gdb/gdb.mk7
2 files changed, 22 insertions, 1 deletions
diff --git a/package/gdb/Config.in b/package/gdb/Config.in
index bfbc8d8bb..9622948b4 100644
--- a/package/gdb/Config.in
+++ b/package/gdb/Config.in
@@ -46,4 +46,20 @@ comment "full gdb on target needs a toolchain w/ wchar"
depends on !BR2_sh && !BR2_sh64 && !BR2_avr32 && !BR2_microblaze && !BR2_bfin
depends on !BR2_USE_WCHAR
+if BR2_PACKAGE_GDB_DEBUGGER
+
+config BR2_PACKAGE_GDB_TUI
+ bool "TUI support"
+ help
+ This option enables terminal user interface (TUI) for gdb
+
+ "The GDB Text User Interface (TUI) is a terminal interface
+ which uses the curses library to show the source file, the
+ assembly output, the program registers and GDB commands in
+ separate text windows."
+
+ https://sourceware.org/gdb/current/onlinedocs/gdb/TUI.html
+
+endif
+
endif
diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 41d3689c8..4a194e26b 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -76,7 +76,6 @@ GDB_CONF_ENV = \
GDB_CONF_OPT = \
--without-uiout \
- --disable-tui \
--disable-gdbtk \
--without-x \
--disable-sim \
@@ -86,6 +85,12 @@ GDB_CONF_OPT = \
--without-included-gettext \
--disable-werror
+ifeq ($(BR2_PACKAGE_GDB_TUI),y)
+ GDB_CONF_OPT += --enable-tui
+else
+ GDB_CONF_OPT += --disable-tui
+endif
+
# This removes some unneeded Python scripts and XML target description
# files that are not useful for a normal usage of the debugger.
define GDB_REMOVE_UNNEEDED_FILES