summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Config.in.legacy15
-rw-r--r--package/tzdata/Config.in23
-rw-r--r--package/tzdata/tzdata.mk4
-rw-r--r--system/Config.in23
4 files changed, 43 insertions, 22 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index ce44d0f5c..c3c430cd9 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -101,6 +101,21 @@ endif
###############################################################################
comment "Legacy options removed in 2014.05"
+config BR2_TARGET_TZ_ZONELIST
+ default BR2_PACKAGE_TZDATA_ZONELIST if BR2_PACKAGE_TZDATA_ZONELIST != ""
+
+config BR2_PACKAGE_TZDATA_ZONELIST
+ string "tzdata: the timezone list option has been renamed"
+ help
+ The option BR2_PACKAGE_TZDATA_ZONELIST has been renamed to
+ BR2_TARGET_TZ_ZONELIST, and moved to the "System configuration"
+ menu. You'll need to select BR2_TARGET_TZ_INFO.
+
+config BR2_PACKAGE_TZDATA_ZONELIST_WRAP
+ bool
+ default y if BR2_PACKAGE_TZDATA_ZONELIST != ""
+ select BR2_LEGACY
+
config BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE
bool "Lua command-line editing none has been renamed"
select BR2_LEGACY
diff --git a/package/tzdata/Config.in b/package/tzdata/Config.in
index 1be68149b..1e6cc0fc6 100644
--- a/package/tzdata/Config.in
+++ b/package/tzdata/Config.in
@@ -1,26 +1,9 @@
-comment "tzdata needs an (e)glibc toolchain"
- depends on !BR2_TOOLCHAIN_USES_GLIBC
+# This package is not meant to be user-visible.
+# It gets selected by BR2_TARGET_TZ in system/Config.in
config BR2_PACKAGE_TZDATA
- bool "tzdata"
- depends on BR2_TOOLCHAIN_USES_GLIBC
+ bool
help
Time zone database
http://www.iana.org/time-zones/repository/tz-link.html
-
-if BR2_PACKAGE_TZDATA
-
-config BR2_PACKAGE_TZDATA_ZONELIST
- string "Time zone list"
- default "default"
- help
- Space-separated list of time zones to compile.
-
- The value "default" includes all commonly used time zones. Note
- that this set consumes around 5.5M.
-
- The full list is the list of files in the time zone database source,
- not including the build and .tab files.
-
-endif
diff --git a/package/tzdata/tzdata.mk b/package/tzdata/tzdata.mk
index d5c9f66be..59004736e 100644
--- a/package/tzdata/tzdata.mk
+++ b/package/tzdata/tzdata.mk
@@ -13,10 +13,10 @@ TZDATA_LICENSE = Public domain
TZDATA_DEFAULT_ZONELIST = africa antarctica asia australasia backward etcetera \
europe factory northamerica pacificnew southamerica
-ifeq ($(call qstrip,$(BR2_PACKAGE_TZDATA_ZONELIST)),default)
+ifeq ($(call qstrip,$(BR2_TARGET_TZ_ZONELIST)),default)
TZDATA_ZONELIST = $(TZDATA_DEFAULT_ZONELIST)
else
-TZDATA_ZONELIST = $(call qstrip,$(BR2_PACKAGE_TZDATA_ZONELIST))
+TZDATA_ZONELIST = $(call qstrip,$(BR2_TARGET_TZ_ZONELIST))
endif
# Don't strip any path components during extraction.
diff --git a/system/Config.in b/system/Config.in
index ba225cee1..d69e880d5 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -267,6 +267,29 @@ config BR2_TARGET_GENERIC_GETTY_OPTIONS
endmenu
endif
+config BR2_TARGET_TZ_INFO
+ bool "Install timezone info"
+ depends on BR2_TOOLCHAIN_USES_GLIBC
+ select BR2_PACKAGE_TZDATA
+ help
+ Say 'y' here to install timezone info.
+
+if BR2_TARGET_TZ_INFO
+
+config BR2_TARGET_TZ_ZONELIST
+ string "timezone list"
+ default "default"
+ help
+ Space-separated list of time zones to compile.
+
+ The value "default" includes all commonly used time zones. Note
+ that this set consumes around 5.5M.
+
+ The full list is the list of files in the time zone database source,
+ not including the build and .tab files.
+
+endif # BR2_TARGET_TZ_INFO
+
config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
bool "remount root filesystem read-write during boot"
default y