summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 21eb3c996..deed073e5 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -327,6 +327,13 @@ endef
# included here *must* be in the same directory!
include $(sort $(wildcard linux/linux-ext-*.mk))
+LINUX_PATCH_DEPENDENCIES += $(foreach ext,$(LINUX_EXTENSIONS),\
+ $(if $(BR2_LINUX_KERNEL_EXT_$(call UPPERCASE,$(ext))),$(ext)))
+
+LINUX_PRE_PATCH_HOOKS += $(foreach ext,$(LINUX_EXTENSIONS),\
+ $(if $(BR2_LINUX_KERNEL_EXT_$(call UPPERCASE,$(ext))),\
+ $(call UPPERCASE,$(ext))_PREPARE_KERNEL))
+
$(eval $(kconfig-package))
# Support for rebuilding the kernel after the cpio archive has