summaryrefslogtreecommitdiff
path: root/package/cups/cups.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/cups/cups.mk')
-rw-r--r--package/cups/cups.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index c07dcb464..797d31af3 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -13,6 +13,12 @@ CUPS_INSTALL_STAGING = YES
CUPS_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) DSTROOT=$(STAGING_DIR) install
CUPS_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) DSTROOT=$(TARGET_DIR) install
+# Using autoconf, not autoheader, so we cannot use AUTORECONF = YES.
+define CUPS_RUN_AUTOCONF
+ cd $(@D); $(HOST_DIR)/usr/bin/autoconf -f
+endef
+CUPS_PRE_CONFIGURE_HOOKS += CUPS_RUN_AUTOCONF
+
CUPS_CONF_OPTS = \
--without-perl \
--without-java \
@@ -21,6 +27,7 @@ CUPS_CONF_OPTS = \
--libdir=/usr/lib
CUPS_CONFIG_SCRIPTS = cups-config
CUPS_DEPENDENCIES = \
+ host-autoconf \
$(if $(BR2_PACKAGE_ZLIB),zlib)
ifeq ($(BR2_PACKAGE_SYSTEMD),y)