summaryrefslogtreecommitdiff
path: root/package/cwiid/cwiid.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/cwiid/cwiid.mk')
-rw-r--r--package/cwiid/cwiid.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/cwiid/cwiid.mk b/package/cwiid/cwiid.mk
new file mode 100644
index 000000000..cce7a7fca
--- /dev/null
+++ b/package/cwiid/cwiid.mk
@@ -0,0 +1,30 @@
+################################################################################
+#
+# cwiid
+#
+################################################################################
+
+CWIID_VERSION = 0.6.00
+CWIID_SOURCE = cwiid-$(CWIID_VERSION).tgz
+CWIID_SITE = http://abstrakraft.org/cwiid/downloads
+CWIID_LICENSE = GPLv2+
+CWIID_LICENSE_FILES = COPYING
+
+CWIID_AUTORECONF = YES
+CWIID_INSTALL_STAGING = YES
+
+CWIID_DEPENDENCIES = host-pkgconf host-bison host-flex bluez_utils
+
+# Disable python support. This disables the 2 following things:
+# - wminput Python plugin support
+# - cwiid Python module
+CWIID_CONF_OPT = --without-python --disable-ldconfig
+
+ifeq ($(BR2_PACKAGE_CWIID_WMGUI),y)
+CWIID_DEPENDENCIES += libgtk2 libglib2
+CWIID_CONF_OPT += --enable-wmgui
+else
+CWIID_CONF_OPT += --disable-wmgui
+endif
+
+$(eval $(autotools-package))