summaryrefslogtreecommitdiff
path: root/package/elfutils/0004-fts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/elfutils/0004-fts.patch')
-rw-r--r--package/elfutils/0004-fts.patch68
1 files changed, 33 insertions, 35 deletions
diff --git a/package/elfutils/0004-fts.patch b/package/elfutils/0004-fts.patch
index 7318236d2..fd7c0b22f 100644
--- a/package/elfutils/0004-fts.patch
+++ b/package/elfutils/0004-fts.patch
@@ -22,16 +22,18 @@ So we have several options here:
Of course, the fts_*() functions are only built if they are not
already provided by the C library.
+Based on the former patch by Thomas Petazzoni.
+
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
-Index: b/configure.ac
-===================================================================
---- a/configure.ac
-+++ b/configure.ac
-@@ -276,6 +276,10 @@
+diff -Nrup a/configure.ac b/configure.ac
+--- a/configure.ac 2014-11-07 15:14:42.402119092 +0000
++++ b/configure.ac 2014-11-07 15:16:50.161316781 +0000
+@@ -266,6 +266,10 @@ if test "$ac_cv_func_argp_parse" != yes;
fi
AC_SUBST(ARGP_LIBS)
-
+
+AC_CHECK_HEADER([fts.h],
+ AC_DEFINE([HAVE_FTS_H], [], [Define if <fts.h> is available in C library]))
+AM_CONDITIONAL(HAVE_FTS, test "$ac_cv_header_fts_h" = yes)
@@ -39,24 +41,9 @@ Index: b/configure.ac
dnl Test for zlib and bzlib, gives ZLIB/BZLIB .am
dnl conditional and config.h USE_ZLIB/USE_BZLIB #define.
save_LIBS="$LIBS"
-Index: b/libdwfl/Makefile.am
-===================================================================
---- a/libdwfl/Makefile.am
-+++ b/libdwfl/Makefile.am
-@@ -79,6 +79,9 @@
- if LZMA
- libdwfl_a_SOURCES += lzma.c
- endif
-+if !HAVE_FTS
-+libdwfl_a_SOURCES += fts.c
-+endif
-
- if MUDFLAP
- libdwfl = libdwfl.a $(libdw) $(libebl) $(libelf) $(libeu)
-Index: b/libdwfl/fts.c
-===================================================================
---- /dev/null
-+++ b/libdwfl/fts.c
+diff -Nrup a/libdwfl/fts.c b/libdwfl/fts.c
+--- a/libdwfl/fts.c 1970-01-01 01:00:00.000000000 +0100
++++ b/libdwfl/fts.c 2014-11-07 15:25:08.325879956 +0000
@@ -0,0 +1,1095 @@
+/*-
+ * Copyright (c) 1990, 1993, 1994
@@ -1153,10 +1140,9 @@ Index: b/libdwfl/fts.c
+ errno = oerrno;
+ return (ret);
+}
-Index: b/libdwfl/fts_.h
-===================================================================
---- /dev/null
-+++ b/libdwfl/fts_.h
+diff -Nrup a/libdwfl/fts_.h b/libdwfl/fts_.h
+--- a/libdwfl/fts_.h 1970-01-01 01:00:00.000000000 +0100
++++ b/libdwfl/fts_.h 2014-11-07 15:26:00.806777392 +0000
@@ -0,0 +1,131 @@
+/*
+ * Copyright (c) 1989, 1993
@@ -1289,19 +1275,31 @@ Index: b/libdwfl/fts_.h
+__END_DECLS
+
+#endif /* fts.h */
-Index: b/libdwfl/linux-kernel-modules.c
-===================================================================
---- a/libdwfl/linux-kernel-modules.c
-+++ b/libdwfl/linux-kernel-modules.c
+diff -Nrup a/libdwfl/linux-kernel-modules.c b/libdwfl/linux-kernel-modules.c
+--- a/libdwfl/linux-kernel-modules.c 2014-08-27 10:25:17.000000000 +0100
++++ b/libdwfl/linux-kernel-modules.c 2014-11-07 15:27:10.783974209 +0000
@@ -29,7 +29,11 @@
/* We include this before config.h because it can't handle _FILE_OFFSET_BITS.
Everything we need here is fine if its declarations just come first. */
-
+
+#ifdef HAVE_FTS_H
#include <fts.h>
+#else
+#include "fts_.h"
+#endif
-
+
#include <config.h>
-
+
+diff -Nrup a/libdwfl/Makefile.am b/libdwfl/Makefile.am
+--- a/libdwfl/Makefile.am 2014-08-27 10:25:17.000000000 +0100
++++ b/libdwfl/Makefile.am 2014-11-07 15:17:57.682478408 +0000
+@@ -79,6 +79,9 @@ endif
+ if LZMA
+ libdwfl_a_SOURCES += lzma.c
+ endif
++if !HAVE_FTS
++libdwfl_a_SOURCES += fts.c
++endif
+
+ libdwfl = $(libdw)
+ libdw = ../libdw/libdw.so